You'll see this error if you try to go to a website with an outdated security code. Chrome protects your privacy by not letting you connect to these sites.

If you own this website, try to set your server to use TLS 1.2 and TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256, instead of RC4. RC4 is no longer considered secure. If you can't turn off RC4, make sure that other non-RC4 ciphers are turned on.

Community content is available under CC-BY-SA unless otherwise noted.